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C O U R S E  O U T L I N E  
 

 What to use a spreadsheet for 

 Exploring Excel’s menus and toolbars 

 Columns and Rows 

 Workbook vs. worksheet 

 Planning your worksheet 

 Entering your worksheet 

 Using formulas 

 Speeding up functions with the Fill and AutoSum commands 

 Formatting your worksheet with lines/color, etc 

 Creating charts 

 Picking the right chart 

 Formatting your charts 

 Copying charts or spreadsheet information to other programs such as 

PowerPoint or Word 

 Recording and using Macros 

 

W H E N  T O  U S E  A  S P R E A D S H E E T  
 
Spreadsheets are primarily used for organizing and calculating a series of related data including 

numbers and text. 

 

It can use formulas to summarize and analyze the numerical data. It also has the ability to create 

graphic charts from the spreadsheet data. 

 

Spreadsheets remain one of the main computer programs for business.  Common applications 

are: 

 Sales summaries 

 Performance tracking 

 Invoice creation 

 Research analysis 

 Budgets and other financial data 
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E X P L O R I N G  E X C E L  

What you will learn from this lesson 

 Explore the workbook window. 

 Navigate through the workbook. 

 Open an existing file. 

 Create an Excel worksheet. 

 Save your work to a file. 

 Quit Excel. 

 

Starting Excel 97/2000 

1. Click the Start button in the lower-left corner. 

2. Position the mouse pointer on Programs. 

3. Click Microsoft Excel. 

Exploring the Excel 97/2000 window 
 

When you start working in Excel, you begin using a workbook that contains screens called 

worksheets. They are identified as Sheet1, Sheet2, and so on.  As you become more familiar with 

the available options in Excel, you can customize the menus and add buttons to the toolbars.  

 

 

 

 

Worksheet or 
chart name 

Menu bar 
Standard toolbar 

Formatting toolbar 
Formula bar 

Scroll bars 
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Moving around in the Excel 97/2000 worksheet 
 

There are a number of ways to move around in a worksheet. Moving from one cell to another in 

Excel is quick and easy. The ways to move from cell to cell include clicking a cell or using the 

Go To command, the scroll bars, the arrow keys, or the HOME, END, PAGE UP, and PAGE DOWN 

keys. 

Moving within a window 

 To select any cell, click it. For example, click cell A1. 

 To move one cell to the right, press TAB, or to move one cell to the left, press SHIFT+TAB. 

 To move one cell down, right, up, or left, use the arrow keys.  

 To move to the first column of the worksheet, press HOME. 

 

Moving around the worksheet 

1. To move one screen down, press PAGE DOWN. 

2. To move one screen up, press PAGE UP. 

3. To move to the uppermost-left cell, A1; press CTRL+HOME. 

4. To move to any cell, on the Edit Menu, click Go To, and type J18 or any cell number. 

5. Press CTRL+HOME to return to cell A1. 

 

Creating an Excel 97/2000 workbook 

 

1. On the File menu, click New. 

2. On the General tab, double-click Workbook to open a new one. 

3. Click cell B2, and type Student List. 

4. On the File menu, click Save, type Book 1, and click OK. 

Saving your work 
When you create a workbook, regardless of which method you use, you must 

save your work in a logical place on the computer. Just like filing a document 

in a file drawer, storing a computer document requires some attention to how 

you name the document and where you place it so you can easily find it again. 

Unless you specify otherwise, Excel 97/2000 saves all workbooks to a default folder on your 

computer called My Documents. 

 

 
 
 
 

Note 
There is a difference 
between a workbook 
and a worksheet. A 
workbook can contain 
many worksheets. 
Each worksheet can 
contain up to 256 
columns across and 
65,536 rows down. 
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Saving for the first time 
When you save the file for the first time, you should name the file as descriptively but as briefly 

as possible.  

Saving a new workbook 

1. On the File menu, click Save. 

2. Click the Save In arrow, and choose a location for your workbook. 

3. In the File name box, type Student List. 

4. To save the workbook, click Save. 

 
Saving an existing workbook 

Saving an existing file to the same file name, location, and format 

1. On the File menu, click Save. 

2. Click OK. 

3. Close the workbook. 

 
Opening a workbook from inside Excel 97/2000 

Opening an existing file with the menu bar 

1. On the File menu, click Open.  

– or – 

Press CTRL+O. 

2. Double-click Book 1 (or any file you want to open). 

– or– 

Select the file name, and click Open. 

 

Quitting Excel 97/2000 
There are several ways to quit Excel 97/2000. Always follow proper procedures, or your work 

may not be saved. All Office 97/2000 applications prompt you to save changes if you try to quit a 

program without saving your open workbooks. 
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G A T H E R I N G  D A T A  F O R  S I M P L E  C A L C U L A T I O N S   

W h a t  yo u  w i l l  l e a r n  f r o m  t h i s  l e s s o n  

 Start a new workbook.  

 Enter and format a title. 

 Modify the text style and font size. 

 Enter column headings and adjust 
column width. 

 Move data. 

 Edit data. 

 

Starting new workbooks 
1. Open a new worksheet. 

2. On the File menu, click Save As. 

3. Type Technology as the file name. 

4. Click the Save button. 

 

Entering and formatting titles 
Using titles on the worksheets makes it easier to read and understand the information shown. 

You can retain the existing styles, create your own styles, or customize your own workbook 

template. The next exercise illustrates how easy it is to enter and modify font styles and sizes in 

your worksheet. 

Entering and formatting a title on the worksheet 

1. With the Technology worksheet open, move the pointer to cell E3, type Technology 

Challenge, and then press ENTER. 

2. Click cell E3. 

3. On the Formatting toolbar, click the Font box, and click Arial. (You may have to use the 

down arrow next to the Font box to find Arial.) 

4. On the Formatting toolbar, click the arrow next to the Font Size box, click 14, and then 

click the Bold button. 
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Entering column headings and adjusting widths 
Column headings help you and others understand the data or information you have entered on 

your worksheet. Sometimes the column heading is too large to fit into a column. Even though it 

does not show the entire title or formula, the cell still contains everything you entered into it. 

This exercise shows you how to increase or decrease the column width to fit the information you 

are entering. 

Entering column headings and adjusting their widths 

1. Using the Technology worksheet, click cell B5, and type Dates in cell 

B5. 

2. Press TAB to go to cell C5, and then type Elementary Schools. 

3. Press TAB to go to cell D5, and then type Secondary Schools. 

4.  Schools. One cell will overlap the other. 

5. Press ENTER.  

6. At the top of the worksheet, position the pointer at the top of the grid 

between columns C and D until the pointer changes into a double-

arrow line and then double-click. 

7. Repeat steps 4 and 5 between cells D and E. 

8. Select the words Technology Challenge, and move the + pointer to a cell line until it 

changes to an arrow. 

9. Click and drag the text to begin in cell C3. 

Note 
The pointer 
becomes a 
 

 
 
or double-arrow 
when it is placed 
between columns 
at the top of a 
chart. 
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Arranging text with the Copy, Paste, and Cut commands 
With Excel 97/2000, it is easy to modify data. When you use the features in Excel 97/2000 to 

create a table, you may decide on a different order of column heads or you may want to revise 

them. It is important to make changes before you build a formula for the chart in order to 

maintain correct calculations. 

Using the Cut, Paste, and Copy commands to arrange text 

1. Using the Technology worksheet, right-click cell C3, and click Cut. 

2. Right-click cell C1, and click Paste. 

3. Right-click cell D5, and click Cut. 

4. Right-click cell D10, and click Paste. 

5. Right-click cell C5, and click Cut. 

6. Right-click cell D5, and click Paste. 

7. Right-click cell D10, and click Cut. 

8. Right-click Cell C5, and click Paste. 

9. Try dragging cell C5 and cell D5 to new locations as you did in the previous exercise.  

 

 
 
 

Entering data 
Using Excel 97/2000 is a powerful way to enter and display data or text. For example, you can 

have Excel 97/2000 display a date showing the month, day, and year with the time, or showing 

only the first letter  

of the month, followed by a two-digit year. Numbers can be displayed as whole numbers, 

numbers with decimals, or numbers written in scientific notation. 

Entering data for growth of World Wide Web sites in U.S. schools 

Note 

Usually Cut is used 
to move the contents 
of a cell or cells to a 
different location. 

Copy is used to 
duplicate the 
contents of a cell or 
cells in another 
location. 
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1. Open the Technology workbook.  

2. Starting in cell B6, type the following information into the worksheet, under the 

corresponding headings. 

3. Save your file. 

 

Dates Elementary Secondary 

1/1/95 85 110 

4/1/95 160 360 

7/1/95 225 380 

10/1/95 250 660 

1/1/96 425 900 

4/1/96 800 1400 

6/1/96 1100 1720 

 
 

Performing simple calculations 
Using Excel 97/2000, you can perform a wide range of mathematical calculations and functions 

according to what you need from your data. To calculate sums (totals) and percentages, use the 

mathematical operation of adding numbers to get a total, and then divide each number that was 

just added by that total. 

Calculating the sum of schools with Web sites 

1. In the Technology workbook, click cell E5, type Total Sites, and press ENTER. 

2. Click cell E5 again, and on the Formatting toolbar, click the Bold button. 

3. Click cell E6, and on the Formula toolbar click the Edit Formula button (the = sign). 

4. Click the Functions arrow, and choose Sum. (C6:D6 appears in the window.) 

5. Click OK. 

6. To sum each pair of numbers, click E6 and drag the fill handle from E6 to E12. 

 

Note 
When you enter data 
in a column format, 
you may find it easier 
and faster to 
highlight the data 
area first, then just 
push TAB on your 
keyboard after each 
entry. 
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Calculating the percentage of schools with Web sites by category  

1. Click cell F5, type % of Elem schools, and then press ENTER. 

2. Click cell F5 again, and then click the Bold button on the Formatting toolbar. 

3. Click cell G5, type % of Sec schools, and press ENTER. 

4. Click cell G5 again, and on the Formatting toolbar click the Bold button. 

5. Click F6, and click the Edit Formula button (the = sign). 

6. Type C6/E6, and click OK. 

7. On the Formatting menu, click Cells. On the Number tab, choose Percentage, and then 

type 2 in the decimal places. 

8. Click F6, and drag the fill handle to F12 to calculate the percentage for each pair of 

numbers. Click OK. 

9. Repeat steps 3 through 8 for Secondary Schools using the formula D6/E6 to calculate the 

percentage. 
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U S I N G  N U M B E R S ,  F O R M U L A S ,  A N D  F U N C T I O N S   

W h a t  yo u  w i l l  l e a r n  f r o m  t h i s  l e s s o n  

 Practice using the Sort function. 

 Create a one-input data table. 

 Create a budget for a school 
function. 

 

 

 

Sorting functions of Excel 97/2000 

 
Recording names and addresses can be a full-time job. Just as soon as you have everyone in the 

correct order, you have a new person whose last name starts with the letter C. With Excel 

97/2000, sorting the names by last name, city, or even by birthday is quick and easy. 

Alphabetizing names 

1. Starting with the column headings in cell A3, create a list of names on your worksheet. Enter 

each name, e-mail address, and city in separate columns, similar to the example shown 

below. Highlight your worksheet from the A3 cell down and across to the C10 cell. 

 

# A B C 

3 Name e-mail address City 

4 Juanita Juanita@gj.net Delta 

5 John John@iti2.net GJ 

6 Roy Roy@gj.net GJ 

7 Tom Tom@aol.com Fruita 

8 Kim Kim@gj.net Mack 

9 Sean Sean@aol.com GJ 

10 Georgia Georgia@gj.net Clifton 

 
2. Select the data table. 

3. On the Data menu, click Sort. 

4. Under Sort by, select Name, and then click Ascending.  

5. Click OK. 
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Creating a one-input data table 
Using Excel 97/2000, you can learn the costs associated with making payments on purchases. 

You can easily calculate monthly payments based on interest and balance due on purchases. In 

the next exercise, you can calculate monthly payments based on interest and total cost of a car, 

showing how the loan term and interest rates affect monthly payments. 

Calculating car payments 

1. Open a new workbook. 

2. Click Sheet2 at the bottom of the window. 

3. In cell C2, type Car Payment Schedule. 

4. Type the following text and formulas in the cells shown in the chart: 

 

Row # Column C Column D 

2 Car Payment 

Schedule 
 

3   

4 Down Payment None 

5 Interest Rate 8% 

6 # of Months 

(term) 

36 

7 Loan Amount $5000 

8   

9   

10 Payments  

 

5. Click cell C11, and on the Formula toolbar, click the Edit Formula button (the = sign). 

6. Click the Functions arrow, and click PMT, if visible. or – Click More Functions. 

 

 

 

Note 
When you enter 
a formula and 
press ENTER, 
the result 
appears in the 
cell, and the 
formula is 
displayed in the 

Formula box. 
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7. In the Function category, click Financial.  

8. In the Function name, click PMT, and then click OK. 

9. Click the Shrink button at the right of the input area, click D5 on the worksheet, and then 

press ENTER. 

10. In the Rate box, click after D5, and type /12. 

11. Click the Nper window, and click the Shrink button. 

12. Click D6 on the worksheet, 

and press ENTER. 

13. Click the Pv window, and click 

the Shrink button. 

14. Click D7 on the worksheet, 

and press ENTER. 

15. Click OK. 

16. To change the months of the 

loan to 24, type 24 in cell D5. 

17. To change the interest rate to 

12.5 percent to demonstrate 

how the payment changes, type 

12.5 in cell D4. Try several 

combinations on your own, and 

see how it works. 

18. Close the workbook without saving it. 
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Order of calculation in Excel 97/2000 
You have just discovered one easy formula in Excel 97/2000. There are many others that help 

you calculate or analyze everything from finances to statistical sampling plans. When you 

combine several mathematical steps in a formula, they are performed in a specific order. Excel 

97/2000 will start calculating from the left to the right according to the following order of 

operations: 

 () Parentheses 

 - Negative number if used with one operand 

 % Percentage 

 ^ Exponentiation 

 * and / Multiplication and division 

 + and - Addition and subtraction 

 &    Connects two text values to produce a continuous text value 

 =,<,<=, >, >=, <> Comparison operators 

 

For reference, the Comparison operators are: 

 = Equal to 

 < Less than 

 <= Equal to or less than 

 > Greater than 

 >= Equal to or greater than 

 <> IS Not equal to 

 
 

C R E A T I N G  A  B U D G E T  
 

Entering budget categories 
Creating a budget involves entering the categories and specific items into the worksheet. The first 

step to creating a budget in Excel 97/2000 is to determine the budget categories and enter them in 

the worksheet. 

Entering categories for a budget 

1. Open a new workbook 

2. Click cell A2, type the title Budget: Awards Dinner, click Budget, and then, on the 

Formatting toolbar, click the Bold button. 

3. Increase the width of column A to 23. 

4. Click Budget, drag it to cell D2, and then click the Merge and Center button. 
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5. Click cell B3, and type Items; click cell C3, and type Budget; and in cell D3, type Actual. 

6. Click cell A4, and type Supplies; click cell B4, and type Paper Products; and then click 

cell B5, and type Decorations. 

7. Double-click between columns B and C to fit the text to the cell. 

 

 

8. Click cell A7, and type Food; click cell B7, and type Meals; and click cell B8, and type 

Beverages. 

9. Click cell A10, and type Awards; click cell B10, and type Certificates. 

10. Click cell A13, and type Miscellaneous; and then click cell B13, and type Custodial. 

11. Click in cell A16, and type Totals; on the Formatting toolbar, click the Align Right 

button. 

12. Click cell B3, drag it to cell D3, and then click the Bold button on the Formatting 

toolbar. 

13. Click cell A4, drag it to cell A16, and then click the Bold button on the Formatting 

toolbar. 

 
Entering budgeted amounts and formulas 

Placing budgeted amounts in formulas 

1. In the Budget workbook from the previous lesson, click cell C4 and type 50.00. 

2. Click cell C5, and type 25.00. 

3. Click cell C7, and type 250.00. 

4. Click cell C8, and type 30.00. 

5. Click cell C10, and type 75.00. 

6. Click cell C13, and type 65.00. 

7. Click cell C4, drag it to cell C16, and then click Currency Style ($). 

8. Click cell C16, click the Edit Formula button (the = sign), and on the Formula bar, click 

Sum.  

9. In Sum Number1, type C4:C13, and click OK. 
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Entering actual amounts  

Completing the budget process with actual amounts 

1. In the Budget workbook from the previous lesson, click cell D4, and type 43 

2. Click cell D5, and type 30 

3. Click cell D7, and type 238. 

4. Click cell D8, and type 27 

5. Click cell D10, and type 60 

6. Click cell D13, and type 60 

7. Click cell D4, drag it to cell D16, and then click the Currency Style button ($). 

8. Click cell C16, drag it to cell D17, and then press ENTER. 

 

 

 
 
 

E M P H A S I Z I N G  Y O U R  P O I N T  W I T H  C H A R T S   
 

W h a t  yo u  w i l l  l e a r n  f r o m  t h i s  l e s s o n  

 Create charts with worksheet data. 

 Modify standard graphs. 

 Create do-it-yourself (DIY) charts. 

 Use pie charts with your data. 

 

Starting the Chart Wizard 
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The Chart Wizard shows each step along the path from entering raw data to completing a 

professional-looking graph. You can transform numbers into graphs, illustrating the power of 

visually oriented information to strengthen presentations. 

Using the Chart Wizard to get started 

1. Select all of the data in the Technology worksheet, including the headings, but not the 

main title or totals. 

 

 

2. On the Standard toolbar, click the Chart Wizard button. 

 

3. On the Standard Types tab, in Chart type, click Column. 

4. In Chart sub-type, click Clustered column with a 3-D visual effect. 

5. Click the Press and hold to view sample button to see a sample of your data in the 

clustered column 3-D format. 

6. Click Next twice. 

 

 
 

Adding titles 
A graph title identifies what the graph presents and explains the data. 

1. With the Technology workbook open, on the Title tab, in Chart title, type Technology 

Challenge. 
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2. In the Value (Z) axis, type Number of Web Sites. (The Z-axis title is available but not the Y-

axis, because the Y-axis extends back into the chart.) 

3. Click the Gridlines tab to select type of lines to show on your graph. 

4. In Category (X) axis, check Major gridlines, and click again to remove. 

5. To see how the graph could look, in Value (Z) axis, check Major gridlines. 

6. To move the legend to the bottom, click Bottom on the Legend tab. 

7. On the Data Labels tab, click Show value, Show label, and then None. 

8. On the Data Table tab, click the Show data table option to see a table, and click again to 

remove the table. 

9. Click Next for Chart Location. 

10. Click As new sheet. 

11. Click Finish to complete the chart process. 

Attaching the graph as a new sheet makes it easier to print a chart. You now have a readable and 

easy-to-understand chart. Attaching the chart as an object has the advantage of providing an 

immediate view of changes to the chart as you change the data. 

 

 
 
 

Rotating Z-axis titles and enlarging chart titles 
The Z-axis title might look cleaner if it were rotated. The main graph title would be easier to read 

if it were a larger font size. You can change them both. 

Rotating Z-axis titles and enlarging chart titles 

1. In the chart from the previous lesson, click the chart title. 

2. On the Formatting toolbar, change the font size to 18. 
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3. Click the title, and position the pointer on the bottom line of the title, and move the title to 

the top center of the chart. 

4. Right-click Number of Web Sites. 

5. Click the Format axis title dialog box. 

 

 

6. On the Alignment tab, click the Red Diamond text line, and drag it up to the top of the 

semicircle. 

7. Click the Font tab, and change the text to bold and 14-point. 

8. Click OK. 

9. Right-click the ―Technology Challenge‖ chart title. 

a) Click Format Chart. 

b) Click the Font tab, and change the text to bold and 20-point. 

c) Click OK. 

 

Adding texture to your background 
The plain, gray background can be changed to a colorful texture. If you have a color printer, a 

textured background will emphasize your chart. 

Adding texture to your background 

1. On the graph background, right-click Walls. 

2. Click Format Walls. 

3. On the Patterns tab, click Fill Effects. 

4. On the Texture tab, click the Parchment color block in the third column of the first row. 

5. Click OK to close the Fill Effects window. 

6. Click OK to close the Patterns tab. 

7. On the graph background, right-click Floor. 

8. Click Format Floor. 

9. On the Patterns tab, click Fill Effects. 

10. On the Texture tab, click the Green marble color block in the first column of the third row. 

11. Click OK to close the Fill Effects window. 

12. Click OK to close the Patterns tab. 
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13. On the File menu, click Save. 

 

 
 
 

 

 

Changing colors of data bars 
It is easy to change data bar colors to enhance your chart. 

Adding colors to enhance data bars 

1. Right-click the first data bar. 

2. Click Format Data Series. 

3. On the Patterns tab, click Bright yellow in the fourth row. 

4. Click OK. 

5. Right-click the second data bar. 

6. Repeat steps 1 through 4, and click Bright green in the fourth row. 
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Rotating charts 
Sometimes it is easier to understand a chart if it is viewed in 3-D. Using Excel 97/2000 you can 

modify your chart to show it from any view—top, bottom, right, left—or you can create 3-D 

charts. 

Rotating charts 

1. Right-click Walls. 

2. Click 3-D View. 

3. In the Elevation dialog box, type 15. 

4. In the Rotation dialog box, type 40. 

5. Click the Auto scaling and the Right angle axes boxes. 

6. Click Apply. 

7. Click OK. 
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Adding depth to charts 
The illusion of depth adds dimension to your chart. Using Excel 97/2000 you can easily modify 

your charts to show depth. 

Adding depth to your chart 

1. Click the second bar on your chart. 

2. Press CTRL+1 to open the Format Data Series window. 

3. Click the Options tab. 

4. In the Gap depth dialog box, type 170. 

5. In the Gap width dialog box, type 90. 

6. In the Chart depth dialog box, type 699. 

7. Click OK. 
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Viewing data with pie charts 
Pie charts are easy to understand, and with Excel 97/2000 and they are easy to make. 

Creating pie charts 

Visually presenting data with Excel 97/2000 pie charts 

1. With the Technology workbook open, click cell B3, and then press SHIFT while you click 

B10. 

2. Press CTRL while you click cell D3 and drag the pointer to select cells D3 through D10. 

3. Click the Chart Wizard button. 

4. Under Chart type, click Pie, and In Chart sub-type, click Pie with a 3-D visual effect (first 

row, second chart). 

5. Click Next. 

6. On the Series tab, click Next, and on the Title tab, click Next. 

7. Click As new sheet. 

8. Click Finish. 
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Modifying pie charts 

Emphasizing data and text in your pie charts  

1. Click Title. 

2. Right-click (chart) Title to open the Format Chart Title dialog box. 

3. On the Font tab, click Bold, change the point size to 36, and then click OK. 

4. Right-click the Legend box to open the Format Legend dialog box. 

5. On the Font tab, click Regular, and then change the point size to 16. 

6. On the Placement tab, click Bottom, and click OK. 

7. Click the Legend box. 

8. Click the size handle at the bottom, and drag it down to increase the length of the Legend 

box. 

9. Click the size handle at the side of the Legend box, and drag it left to increase the width of 

the box. 

10. Right-click inside Pie to open the Format Data Series dialog box. 

11. On the Data Labels tab, click Show value. 

12. Click Show legend key next to label, and click OK. 

13. Right-click one of the Data Labels to open the Format Data Labels dialog box. 

14. On the Font tab, click Regular, click 14, and click OK.  
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Your chart should match the following example: 

 
 
 
 

P U T T I N G  I T  A L L  T O G E T H E R  W I T H  E X C E L   

W h a t  yo u  w i l l  l e a r n  f r o m  t h i s  l e s s o n  

 Insert and link Excel graphs into your report. 

 Insert and link Excel charts into your report. 

 

Creating linked data charts 
Data from a worksheet can be linked into a Word document. Every time the numbers in the 

worksheet change, the corresponding numbers in the Word document will be updated. 

Linking data charts into a Word document 

1. Open the Word document that you want to use for your report. 

2. Open the Excel 97/2000 worksheet named Technology, which you saved earlier. 

3. Select the area of the worksheet to be copied into the Word document.  
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4. Press CTRL+C. 

– or – 

On the Standard toolbar, click the Copy button. 

5. Click in your Word document where you want to insert the data table 

6. On the Edit menu, click Paste Special. 

7. Click Paste link, Microsoft Excel Worksheet Object, and Float over text. 

8. Click OK, and save your Word 97/2000 document. 

 

 

 
Your data chart is now part of your document. This method of linking the data chart to your 

document uses the least amount of system memory. Any changes you make in the Excel 97/2000 

worksheet will be reflected in your Word document. 

 

Creating linked graphs 
Linking a graph from Excel 97/2000 is an easy way to ensure that any changes to your graph in 

Excel 97/2000 are carried over to your graph in a Word 97/2000 document. 

Linking a graph 

1. Using the same Word document you used in the previous lesson, click the location in that 

Word document where you want to insert your graph. 

2. Click the graph tab at the bottom of the Excel 97/2000 screen to select the colorful graph. 

(Sheet1 contains the actual data. If you made several graphs, confirm which one is saved 

under which general name.) 
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3. Click the outside edge of the graph to select it. Sizing handles will appear, marking the graph 

corners and side boundaries. They can be grabbed to move or change the size of the graphic. 

4. On the Standard toolbar, click the Copy button, or press CTRL+C. A moving dotted line will 

outline your graph. 

5. On the Edit menu, click Paste Special. 

6. Click Paste Link and Float over text, and then click OK, just as in the previous exercise. 

7. Size your graph, and move it into position in your document. 

8. Save the Word document and the Excel workbook, and close the documents. 

 

Excel 97/2000 has linked your chart and graphic from your worksheet to your document. You 

can edit through Word 97/2000 into Excel 97/2000, but it may be slower than entering the 

changes directly in Excel 97/2000, depending on your computer speed and system memory. 

MACROS 
 

In Excel, if you perform a task repeatedly, you can automate it with a macro. A macro is a stored 

list of commands and keystrokes. They are automatically executed when you run the macro. 

Before you record or write a macro, 

 Plan the steps and commands you want the macro to perform. 

 Any keystroke you make while recording a macro, is recorded. This includes 

 mistakes! 

 Macros can be stored so they are available for all workbooks, or only the workbook 

 open when it is created. 

 Macros can be edited after they are created. 

 Macros are great for many things including 

 Creating Headers and footers that are used repeatedly in different workbooks or 

 worksheets 

 Formatting cells 

 Printing a range 

Record Macros 
You create a macro by recording it. There are two steps: 

Step 1: Name the Macro 

Step 2: Record the keystrokes and commands included in the macro. 

1. Click Tools on the menu bar. 
2. Point to Macro. 
3. Click Record Macro. A window opens. 
4. In the Name box, type a name for the macro. 

The first character of the macro name must be a letter. 

Other characters can be letters, numbers, or underscore characters. 
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Spaces are not allowed 

5. If you wish to want to assign a shortcut key to the macro, type a letter in the Shortcut Key text 
box. 

The shortcut key can be an uppercase or lowercase letter. It cannot be anumber or 

special character. 

.To assign a small letter, that you access using CTRL+ the letter, just type the letter. 

To assign a uppercase letter, that you access using CTRL+SHIFT+ the letter. hold 

down the SHIFT key and type the letter. 

Don't use a default Excel shortcut key! The shortcut key will override any default 

Microsoft Excel shortcut keys while the workbook that contains the macro is open. 
6. In the Store macro in box, click the location where you want to store the macro. 
To make the macro available whenever you use Excel, 
Click the arrow at the right side of the Store Macro In box. 
Select Personal Macro Workbook 
To make the macro available for this worksheet only, 
Click the arrow at the right side of the Store Macro In box. 
Select This Workbook. 
7. Click in the description box and type a short description of the macro's function. 
From NOW ON, until you stop recording, every keystroke is being recorded!!! 
8. Perform the actions you wish the Macro to record. Do them in the order you want them performed. 
9. When all actions are completed: 
If the Macro toolbar is displayed, click the Stop Recording button 
Or 
Click Tools on the menu bar. 
Point to Macros 
Click Stop Recording 

Run a Macro 
You can run Macros from 

Tools menu 

Shortcut key if it was assigned 

Run the Macro Using a Shortcut Key 
1. Open the workbook in which you wish to run the macro. 
2. To run the macro using a short cut key 
Hold down the CTRL key and press the shortcut key 
Or 
If the shortcut key was uppercase, hold down the CTRL and the SHIFT key and press the 
shortcut key. 

Run a Macro From the Menu Bar 
1. 1. Open the workbook in which you wish to run the macro. 
2. 2. Click Tools on the menu bar. 
3. 3. Point to Macro. 
4. 4. Click Macros. 
5. 5. Click the name of the macro you wish to run. 
6. 6. Click Run 

Assign a Shortcut Key After a Macro Has Been Created 
7. 1. Click Tools on the menu bar. 
8. 2. Point to Macro. 
9. 3. Click Macros. 
10. 4. Select the macro where you wish to create the shortcut key. 
11. 5. Click the Options button. 
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12. 6. Type a letter in the Shortcut Key text box. 
13. 7. Click OK. 

Edit Macros 
Macros are edited using the Visual Basic Editor. This is a program Excel uses to create macros. 

14. Click Tools on the menu bar. 
15. Point to Macro 
16. Click Macros. 
17. Select the macro you wish to edit. 
18. Click the Edit button. The macro code appears in the window in the Visual Basic editor. IT 

is written in a Visual Basic language. Unless you know the language, it is often easier to 
just record the macro again, instead of editing it. 

19. Make any corrections. 
20. When changes are complete, Click File on the menu bar. 
21. Click Close. Changes are automatically saved. 

Delete Macros 
22. Click Tools on the menu bar. 
23. Point to Macro. 
24. Click Macros. 
25. Select the macro you wish to edit. 
26. Click the Delete button in the Macro window. 
27. Click Yes in response to the prompt asking if you really wish to delete the macro. 

Attach Macros to Buttons or Drawing Objects 
Macros can be attached to buttons or drawing objects. When you click the button or drawing 
object, the assigned macro automatically runs. 
 

Attach a Macro to a Button 
28. This assumes the macro is already created. 
29. Click View on the menu bar. 
30. Point to Toolbars. 
31. Click Forms to display the Forms toolbar. 
32. Click the Button icon. 
33. On the worksheet, move the cursor to the desired location for the button. 
34. Drag to create the button. When you release the button, the Assign Macro window opens. 
35. Click on the macro that you wish to attach to the button. 
36. Click OK. 
37. To change the default name on the button 
38. Click on the button with the right mouse button. 
39. Click Edit text. 
40. Edit the text as desired. Click outside the button to deselect it. 


